<!DOCTYPE html><html class="no-js" lang="en-CA"
xmlns:fb="http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><title>2020 B.C. Election - History and Background - My Kootenay Now</title><link href="//www.google-analytics.com" rel="dns-prefetch"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes"><meta name="description" content=""><link rel="shortcut icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="114x114" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="72x72" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><meta property="og:site_name" content="My Kootenay Now"><meta property="og:url" content="https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/"/><meta property="og:type" content="article" /><meta property="og:title" content="2020 B.C. Election &#8211; History and Background" /><meta property="og:description" content="Before voters head to the polls on Saturday, MyKootenayNow.com is providing a look at how we got where we are, diving into ... more &#8250;"><meta property="og:image" content="https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="314" /> <script data-ad-client="ca-pub-3985045263764181" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <link rel="stylesheet" id="wp-forecast-css" href="https://www.mykootenaynow.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" /> <script>if(typeof WebFontConfig==="undefined"){WebFontConfig=new Object();}
WebFontConfig['google']={families:['Oswald:300,400,700','Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};(function(){var wf=document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf,s);})();</script> <meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.mykootenaynow.com/#website","url":"https://www.mykootenaynow.com/","name":"My Kootenay Now","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.mykootenaynow.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/#primaryimage","inLanguage":"en-CA","url":"https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2.jpg","width":1920,"height":1280,"caption":"The B.C. Legislature in Victoria. (Supplied by Pixabay)"},{"@type":"WebPage","@id":"https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/#webpage","url":"https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/","name":"2020 B.C. Election - History and Background - My Kootenay Now","isPartOf":{"@id":"https://www.mykootenaynow.com/#website"},"primaryImageOfPage":{"@id":"https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/#primaryimage"},"datePublished":"2020-10-23T21:40:42+00:00","dateModified":"2020-10-23T21:42:18+00:00","author":{"@id":"https://www.mykootenaynow.com/#/schema/person/b9c26f39896f5c87952e057c3264fa69"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/"]}]},{"@type":["Person"],"@id":"https://www.mykootenaynow.com/#/schema/person/b9c26f39896f5c87952e057c3264fa69","name":"Bradley Jones","image":{"@type":"ImageObject","@id":"https://www.mykootenaynow.com/#personlogo","inLanguage":"en-CA","url":"https://www.mykootenaynow.com/wp-content/uploads/2020/04/86269439_10158041491615539_5137221815948541952_o.jpg","caption":"Bradley Jones"}}]}</script> <link rel='dns-prefetch' href='//ras.vistaradio.ca' /><link rel='dns-prefetch' href='//cdn.vistaradio.ca' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="My Kootenay Now &raquo; Feed" href="https://www.mykootenaynow.com/feed/" /><link rel="alternate" type="text/calendar" title="My Kootenay Now &raquo; iCal Feed" href="https://www.mykootenaynow.com/community-calendar/?ical=1" /> <script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mykootenaynow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
/*! This file is auto-generated */
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:0 0 !important;padding:0 !important}</style><link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://www.mykootenaynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='tribe-tooltip-css'  href='https://www.mykootenaynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='elusive-css'  href='https://www.mykootenaynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://www.mykootenaynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /><link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.mykootenaynow.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.4' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.mykootenaynow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-flexslider-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/flexslider/flexslider-custom.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-social-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/font-icons/social-icons/css/zocial.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-entypo-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/font-icons/entypo/css/entypo.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-symbol-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/font-icons/symbol/css/symbol.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-swipebox-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/swipebox/swipebox.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-bootstrap-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/framework/bootstrap/css/bootstrap.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-theme-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso/css/theme.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='child-style-css'  href='https://www.mykootenaynow.com/wp-content/themes/presso-child/style.css?ver=5.4.2' type='text/css' media='all' /> <script type='text/javascript' src='https://www.mykootenaynow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/2cb6d.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/5e412.js'></script> <script type='text/javascript'>var instant_search={"blog_url":"https:\/\/www.mykootenaynow.com","ajax_url":"https:\/\/www.mykootenaynow.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};</script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/088bf.js'></script> <script type='text/javascript' src='https://cdn.vistaradio.ca/js/iframeResizer.js'></script> <link rel='https://api.w.org/' href='https://www.mykootenaynow.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mykootenaynow.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mykootenaynow.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.mykootenaynow.com/?p=40588' /><link rel="alternate" type="application/json+oembed" href="https://www.mykootenaynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.mykootenaynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F&#038;format=xml" /><meta property="fb:app_id" content="335982600081119"/><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.mykootenaynow.com"><link rel="https://theeventscalendar.com/" href="https://www.mykootenaynow.com/wp-json/tribe/events/v1/" /><style id="vw-custom-font" type="text/css"></style><style type="text/css">::selection{color:#fff;background-color:#3facd6}h1{line-height:1.1}h2{line-height:1.2}h3,h4,h5,h6{line-height:1.4}.header-font,woocommerce div.product .woocommerce-tabs ul.tabs li,.woocommerce-page div.product .woocommerce-tabs ul.tabs li,.woocommerce #content div.product .woocommerce-tabs ul.tabs li,.woocommerce-page #content div.product .woocommerce-tabs ul.tabs li{font-family:Oswald;font-weight:700}.header-font-color{color:#333}.wp-caption p.wp-caption-text{color:#333;border-bottom-color:#333}.body-font{font-family:Open Sans;font-weight:400}.mobile-nav,.top-nav,.comment .author>span,.pingback .author>span,.label,.tagcloud a,.woocommerce .product_meta .post-tags a,.bbp-topic-tags a,.woocommerce div.product span.price,.woocommerce-page div.product span.price,.woocommerce #content div.product span.price,.woocommerce-page #content div.product span.price,.woocommerce div.product p.price,.woocommerce-page div.product p.price,.woocommerce #content div.product p.price,.woocommerce-page #content div.product p.price,.main-nav .menu-link{font-family:Oswald}.primary-bg,.label,.tagcloud a,.woocommerce nav.woocommerce-pagination ul li span.current,.woocommerce-page nav.woocommerce-pagination ul li span.current,.woocommerce #content nav.woocommerce-pagination ul li span.current,.woocommerce-page #content nav.woocommerce-pagination ul li span.current,.woocommerce nav.woocommerce-pagination ul li a:hover,.woocommerce-page nav.woocommerce-pagination ul li a:hover,.woocommerce #content nav.woocommerce-pagination ul li a:hover,.woocommerce-page #content nav.woocommerce-pagination ul li a:hover,.woocommerce nav.woocommerce-pagination ul li a:focus,.woocommerce-page nav.woocommerce-pagination ul li a:focus,.woocommerce #content nav.woocommerce-pagination ul li a:focus,.woocommerce-page #content nav.woocommerce-pagination ul li a:focus,#pagination>span{background-color:#3facd6}a,.social-share a:hover,.site-social-icons a:hover,.bbp-topic-header a:hover,.bbp-forum-header a:hover,.bbp-reply-header a:hover{color:#3facd6}.button-primary{color:#3facd6;border-color:#3facd6}.primary-border{border-color:#3facd6}.top-bar{background-color:#333;color:#eee}#open-mobile-nav,.top-nav a,.top-bar-right>a{color:#eee}#open-mobile-nav:hover,.top-nav a:hover,.top-bar-right>a:hover{background-color:#3facd6;color:#fff}.top-nav .menu-item:hover{background-color:#3facd6}.top-nav .menu-item:hover>a{color:#fff}.main-bar{background-color:#f9f9f9;color:#bbb}.main-nav-bar{background-color:#333}.main-nav-bar,.main-nav>.menu-item>a{color:#fff}.main-nav .menu-item:hover>.menu-link,.main-nav>.current-menu-ancestor>a,.main-nav>.current-menu-item>a{background-color:#3facd6;color:#fff}.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon{background-color:#3facd6}.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count{color:#3facd6}.widget_vw_widget_categories a:hover{color:#3facd6}#footer{background-color:#111}#footer .widget-title{color:#3facd6}#footer,#footer .title,#footer .comment-author,#footer .social-subscription-count{color:#999}.copyright{background-color:#000}.copyright,.copyright a{color:#ddd}</style><style type="text/css" title="dynamic-css" class="options-output">h1,h2,h3,h4,h5,h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:700;color:#333;opacity:1;visibility:visible;-webkit-transition:opacity .24s ease-in-out;-moz-transition:opacity .24s ease-in-out;transition:opacity .24s ease-in-out}.wf-loading h1,h2,h3,h4,h5,h6,{opacity:0}.ie.wf-loading h1,h2,h3,h4,h5,h6,{visibility:hidden}body{font-family:"Open Sans";font-weight:400;font-style:400;color:#666;font-size:14px;opacity:1;visibility:visible;-webkit-transition:opacity .24s ease-in-out;-moz-transition:opacity .24s ease-in-out;transition:opacity .24s ease-in-out}.wf-loading body,{opacity:0}.ie.wf-loading body,{visibility:hidden}</style>
<!--[if lt IE 9]> <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js"></script> <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--> <script data-optimized="1" type="text/javascript" src="https://www.mykootenaynow.com/wp-content/litespeed/cssjs/7762a.js"></script> <script type="text/javascript">jQuery(document).ready(function(){jQuery('body').ihavecookies({title:'Accept Cookies & Privacy Policy?',message:'We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. By continuing to use our website you consent to our Cookie and Privacy Policy. ',delay:600,expires:1825,link:'https://www.vistaradio.ca/privacy/',uncheckBoxes:true});});</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet"><style type="text/css">:root{--purple:#3b3646;--red:#ee4b5a}#gdpr-cookie-message{position:fixed;right:30px;bottom:30px;max-width:375px;background-color:var(--purple);padding:20px;border-radius:5px;box-shadow:0 6px 6px rgba(0,0,0,.25);margin-left:30px;font-family:system-ui}#gdpr-cookie-message h4{color:var(--red);font-family:'Open Sans',sans-serif;font-size:18px;font-weight:500;margin:0 0 10px}#gdpr-cookie-message p{color:#fff;font-size:15px;line-height:1.5em}#gdpr-cookie-message p:last-child{margin-bottom:0;text-align:right}#gdpr-cookie-message a{color:var(--red);text-decoration:none;font-size:15px;padding-bottom:2px;border-bottom:1px dotted rgba(255,255,255,.75);transition:all .3s ease-in}#gdpr-cookie-message a:hover{color:#fff;border-bottom-color:var(--red);transition:all .3s ease-in}#gdpr-cookie-message button{border:none;background:var(--red);color:#fff;font-family:'Open Sans',sans-serif;font-size:15px;padding:7px;border-radius:3px;margin-left:15px;cursor:pointer;transition:all .3s ease-in}#gdpr-cookie-message button:hover{background:#fff;color:var(--red);transition:all .3s ease-in}</style> <script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"33145398"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script> <noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=33145398&cv=2.0&cj=1" />
</noscript></head><body id="top" class="post-template-default single single-post postid-40588 single-format-standard custom-background tribe-no-js tribe-theme-parent-presso tribe-theme-child-presso-child site-layout-boxed site-disable-post-box-effects"><nav id="mobile-nav-wrapper"></nav><aside class="zone takeover"><ins data-revive-zoneid="79" data-revive-target="_blank" data-revive-id="b07d3d41c82582579069d81820142439"></ins></aside><div style="position: fixed; top:0px; left:0px; z-index: -1; background: url(//ras.vistaradio.ca/dist/avw.php?raszid=242) center top no-repeat; background-size: cover; width: 100%; height:100%;"><a href="//ras.vistaradio.ca/dist/ck.php?n=NID&amp;cb=RANDOM_NUMBER" target="_blank" style="display: block; width: 100%; height: 100%;"></a></div><div id="off-canvas-body-inner"><div id="top-bar" class="top-bar"><div class="container"><div class="row"><div class="col-sm-12">
<span id="weather-ajax"></span><div class="weather-zone"><script src= "/bmp-zone-weather.js"></script></div> <script>jQuery.ajax({url:"/wp-content/themes/presso-child/vista/weather-ajax.php",dataType:"text",success:function(data){if(data!=""){jQuery("#weather-ajax").html(data);}}});</script> <div id="listen-live-header"><div class="listen-live-station listen-live-link" data-stream="ckqr" id="hdr-ll-ckqr"><div class="wrapper"><span><img src="https://www.mykootenaynow.com/wp-content/themes/presso-child/vista/_img/icons/play-hdr.png" alt="Listen Live to 99.3 The GOAT"></span>
<span><h3 class="brand-goat">99.3 The GOAT</h3><h4><div class="song-ticker"></div></h4>
</span></div></div> <script>(function($){$('document').ready(function(){$.ajax({url:"/wp-content/themes/presso-child/nowplaying.php?s=CKQR&g=ROCK&l=1&nolist=true&ts="+Date.now()+"",dataType:"text",cache:false,success:function(data){if(data){$("#hdr-ll-ckqr .song-ticker").html(data);$(".time").css('display','none');if($('#hdr-ll-ckqr p.artist').textWidth()+$('#hdr-ll-ckqr .title').textWidth()>='90'){$('#hdr-ll-ckqr .song-ticker').addClass('marquee');}}}});});})(jQuery);</script> </div></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav"><i class="icon-entypo-menu">menu</i></a>
<a id="open-mobile-nav" class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav" title="Search"></a></div></div></div></div><header class="main-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div id="logo" class="" style="/*display: block; text-align: center; margin-bottom: 1em; width: 100%;*/">
<a href="https://www.mykootenaynow.com/" style="white-space: nowrap;">
<span id="mynow-icon"><img src="https://www.mykootenaynow.com/wp-content/themes/presso-child/vista/_img/mynow-icon.png" alt="My Kootenay Now" border="0" width="63" height="63" class="logo-original" /></span>
<span id="mynow-logo"><img src="https://www.mykootenaynow.com/wp-content/themes/presso-child/vista/_img/comm/mykootenaynow.png" alt="My Kootenay Now" border="0" width="100%" height="50" class="logo-original" /></span>
</a></div><div id="station-logo-header" style="/*display: block; text-align: center; width: 100%;*/"><div>
<a href="https://www.mykootenaynow.com/the-goat/">
<img src="https://www.mykootenaynow.com/wp-content/themes/presso-child/vista/_img/station/CKQR.png?201022" alt="99.3 The GOAT" width="" height="" border="0" class="brand-goat" />
</a></div></div></div></div></div></header><div class="main-nav-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/993TheGOAT" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/993TheGOAT" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a>									<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div><nav id="main-nav-wrapper"><ul id="menu-main-navigation" class="main-nav list-unstyled"><li id="nav-menu-item-53" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="https://www.mykootenaynow.com/news/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-bullhorn" aria-hidden="true"></i><span>News</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-55" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.mykootenaynow.com/news/" class="menu-link sub-menu-link"><span>News</span></a></li><li id="nav-menu-item-56" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mykootenaynow.com/submit-news-tip/" class="menu-link sub-menu-link"><span>Submit News Tip</span></a></li></ul></li><li id="nav-menu-item-16687" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/win/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-smiley" aria-hidden="true"></i><span>Win</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-52" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="/community-calendar/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-calendar" aria-hidden="true"></i><span>Events</span></span></a><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-11724" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/" class="menu-link sub-menu-link"><span>Community Calendar</span></a></li><li id="nav-menu-item-11723" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/community/add" class="menu-link sub-menu-link"><span>Submit Event</span></a></li></ul></li><li id="nav-menu-item-63" class="main-menu-item  menu-item-even menu-item-depth-0 nav-listen-live-link menu-item menu-item-type-custom menu-item-object-custom"><a rel="ckqr" href="#" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-play-alt" aria-hidden="true"></i><span>Listen Live</span></span></a></li><li id="nav-menu-item-16944" class="main-menu-item  menu-item-even menu-item-depth-0 menu-icon-on-air menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.mykootenaynow.com/on-air/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-microphone" aria-hidden="true"></i><span>On Air</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-16945" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/on-air/" class="menu-link sub-menu-link"><span>Shows &#038; More</span></a></li><li id="nav-menu-item-16942" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mykootenaynow.com/the-goat/" class="menu-link sub-menu-link"><span>Talent</span></a></li><li id="nav-menu-item-16943" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mykootenaynow.com/contact-us/" class="menu-link sub-menu-link"><span>Contact Us</span></a></li></ul></li><li id="nav-menu-item-23197" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.mykootenaynow.com/news/cancellationsclosures/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-exclamation-triangle" aria-hidden="true"></i><span>Closures</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-23201" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/news/cancellationsclosures/school-notices/" class="menu-link sub-menu-link"><span>School Closures</span></a></li><li id="nav-menu-item-23199" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/news/cancellationsclosures/kootenay-pass-closures-updates/" class="menu-link sub-menu-link"><span>Kootenay Pass Closures &#038; Updates</span></a></li><li id="nav-menu-item-23198" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/news/cancellationsclosures/ferry-updates/" class="menu-link sub-menu-link"><span>Ferry Updates</span></a></li><li id="nav-menu-item-23200" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/news/cancellationsclosures/road-report/" class="menu-link sub-menu-link"><span>Road Closures</span></a></li></ul></li><li id="nav-menu-item-30922" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mykootenaynow.com/local-connections/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-star" aria-hidden="true"></i><span>Local Connections</span></span></a><div class="sub-menu-container"></li></ul></nav></div></div></div></div><div id="page-wrapper" class="container"><div class="row"><div id="page-content" class="col-sm-7 col-md-8"><article id="post-40588" class="post-40588 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="tags clearfix">
<a class="label " href="https://www.mykootenaynow.com/news/" title="View all posts in News" rel="category">News</a></div><h1 class="post-title title title-large entry-title">2020 B.C. Election &#8211; History and Background</h1><hr class="hr-thin-bottom"><div class="social-share">
<span class="header-font">SHARE ON:</span><a class="social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F&amp;t=http://2020%20B.C.%20Election%20&#8211;%20History%20and%20Background" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="social-twitter" href="https://twitter.com/share?text=2020+B.C.+Election+%26%238211%3B+History+and+Background&url=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a><a class="social-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F" title="Share on Google+" target="_blank"><i class="icon-social-gplus"></i></a><a class="social-pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mykootenaynow.com%2F40588%2F2020-b-c-election-history-and-background%2F&amp;media=https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2.jpg&amp;description=http://2020%20B.C.%20Election%20&#8211;%20History%20and%20Background" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a></div><div class="post-meta header-font">
<img src="https://www.mykootenaynow.com/wp-content/uploads/2020/04/86269439_10158041491615539_5137221815948541952_o-80x80.jpg" width="48" height="48" alt="Bradley Jones" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 alignnone photo" />			<a class="author-name vcard author" href="https://www.mykootenaynow.com/talent/bradley/" title="View all posts by Bradley Jones"><span class="fn">Bradley Jones</span></a><span class="post-meta-separator">,</span>
<span class="label-staff">staff</span><span class="post-meta-separator"></span>
<a href="https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/" class="post-date updated" title="Permalink to 2020 B.C. Election &#8211; History and Background" rel="bookmark">Friday, Oct. 23rd, 2020</a></div><div class="post-thumbnail-wrapper">
<a class="swipebox" href="https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2.jpg" title="Permalink to image of 2020 B.C. Election &#8211; History and Background" rel="bookmark"><img width="750" height="420" src="https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2-750x420.jpg 750w, https://www.mykootenaynow.com/wp-content/uploads/2020/10/British-Columbia-Legislature-Victoria-BC-MLA-Stock-Pixabay-2-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" />
</a><div class="vw-featured-image-caption-wrapper"><div class="vw-featured-image-caption">
<i class="icon-entypo-camera"></i> The B.C. Legislature in Victoria. (Supplied by Pixabay)</div></div></div><div class="post-content clearfix"><p>Before voters head to the polls on Saturday, MyKootenayNow.com is providing a look at how we got where we are, diving into the background and history of each local riding.</p><h4>British Columbia</h4><p>The BC NDP are looking for a majority government, the BC Liberals are hoping to unseat the NDP as the ruling government, and the BC Green Party is looking to improve their position in the legislature heading into the 2020 B.C. Election. They all hope to do that by winning local ridings in the East Kootenay, West Kootenay and Kootenay Boundary.</p><p>John Horgan called the snap election back on September 21st, effectively dissolving the legislature and bringing about a fall election one year earlier than required.</p><p>In the 2017 B.C. Election the NDP technically lost, as the Liberals won 43 seats under the leadership of Christy Clark, while the NDP won 41, and the Greens won three. It was the first time since 1952 that a majority government wasn&#8217;t elected, and the first time in Canadian politics that more than one Green Party member had been elected. Although Clark and the Liberals narrowly won the popular vote &#8211; 40.37% to the NDP&#8217;s 40.29% support &#8211; an agreement between John Horgan&#8217;s NDP  and Andrew Weaver&#8217;s Greens forced Clark and the Liberals out of power. Holding 44 seats under the agreement, John Horgan became Premier of British Columbia with the Green Party voting alongside policy decisions with the NDP.</p><p>Approaching the 2020 B.C. Election, the Liberals are looking to take back power. Since 2001, the Liberals had ruled in British Columbia. That election was a landslide victory as Gordon Campbell was named Premier, winning 77 of 79 seats. Campbell would win again in 2005 and 2009 before Clark took leadership of the Liberals in 2011, leading them to victory again in 2013 and in 2017, although they lost a confidence vote following the latest election.</p><p>For the NDP, they are hoping to emerge as a majority government in the B.C. Legislature and continue to have John Horgan run the province as Premier. Taking over as party leader in 2014 from Adrian Dix, Horgan is hoping to make gains from their 41 seats won in 2017, to the 44 needed for a majority. Before gaining power in 2017, the NDP was on a 16-year drought. Mike Harcourt gave the party power in 1991, which they retained in 1996 with a close 39-33 victory over the Liberals under the leadership of Glenn Clark.</p><p>The BC Green Party is looking to make steady progress in 2020. Winning their first seat in B.C. back in 2013, the party was the first with federal or provincial affiliation to win more than one seat back in 2017, when they won three. The party is looking to do all of that with Sonia Furstenau at the helm, a leader that was appointed just seven days before Horgan called the snap election. Furstenau was one of three Greens to win a seat in 2017, alongside Adam Olsen and then-party leader Andrew Weaver. Weaver announced he would be stepping down in 2019 and eventually resigned from caucus in mid-January to sit as an Independent until the next election was called. The party was looking to elect their next leader in June but the COVID-19 pandemic postponed their plans, leaving Furstenau to hit the ground running just days after her leadership victory.</p><h4>Kootenay West</h4><p>The busiest and fullest list of candidates in the entire Kootenays, two independents, representatives for all three major parties, and a BC Conservative are all running in Kootenay West.</p><p>Another NDP stronghold, Kootenay West has historically voted orange. Previously known as Rossland-Trail, the NDP first won the riding in 1972. Christopher D&#8217;Arcy represented the NDP until 1991, a political career that spanned 19 years. Ed Conroy then served two terms until 2001 when Sandy Santori won for the Liberals in the newly-named riding of West Kootenay-Boundary.</p><p>2005 is when <a href="https://www.mykootenaynow.com/40346/kootenay-west-ndp-candidate-katrine-conroy/">Katrine Conroy</a> stepped onto the scene, once again winning the riding for the NDP and holding her seat as MLA for 15 consecutive years. In 2009, the riding was subsequently renamed for a third time to Kootenay West. Back in 2017, Conroy got her first appointment by John Horgan as Minister of Children and Family Development. With an election win in 2020, Conroy has a chance to become the longest-serving MLA in the riding&#8217;s history.</p><p>However, five other candidates are looking to spoil the party.</p><p><a href="https://www.mykootenaynow.com/40475/kootenay-west-bc-green-candidate-andrew-duncan/">Andrew Duncan</a> is representing the Green Party. From Rossland, Duncan has a background in Environmental Science and Physical Geography while also serving as a Search and Rescue Manager.</p><p>The Liberals are looking to <a href="https://www.mykootenaynow.com/40470/kootenay-west-bc-liberal-party-candidate-corbin-kelley/">Corbin Kelley</a> as their candidate. At 19 years old, Kelley is studying Political Science and Economics at Thompson Rivers University, hoping to begin his career in politics if he wins on election night.</p><p>One of 19 Conservatives running in 2020, <a href="https://www.mykootenaynow.com/40427/kootenay-west-ndp-candidate-glen-byle/">Glen Byle</a> is looking to reduce the size of government and the role government plays in the lives of British Columbians. The Trail man said he&#8217;s running on a platform that promotes a healthy environment and healthy finances.</p><p>Vallican&#8217;s <a href="https://www.mykootenaynow.com/40493/kootenay-west-independent-candidate-ed-varney/">Ed Varney</a> is running as one of two independents, while Rossland&#8217;s Fletcher Quince is the other.</p><p>&nbsp;</p><h4>Nelson-Creston</h4><p>The BC NDP have full intentions of holding on to Nelson-Creston, a riding that has strongly supported the NDP since 1971. The difficult task for the party is doing it without Michelle Mungall, who stepped down prior to the election. Mungall served as MLA since 2009, taking over for Corky Evans. Her 11-year career most recently saw her become a high-ranking Minister with the NDP, serving as Minister of Energy, Mines, and Petroleum Resources since 2017 and as Minister of Jobs, Economic Development and Competitiveness since early January. Corky Evans represented the party in the riding from 1991 to 2001, before losing to Liberal MLA Blair Suffredine, although Evans returned to win back his seat in 2005 and served one term before Mungall&#8217;s election win.</p><p>Prior to that, Lorne Dickson was the NDP MLA for the riding from 1972 to 1986. Nelson-Creston briefly went back to support the now-defunct Social Credit Party from 1986 to 1991 by electing Howard Dicks. Between 1952 and 1972, Wesley Drewett Black represented the riding for the Social Credits.</p><p>Back to the modern fight in 2020, <a href="https://www.mycrestonnow.com/27372/nelson-creston-candidate-profile-brittny-anderson-ndp/">Brittny Anderson</a> is looking to fill Mungall&#8217;s shoes for the NDP. The Nelson City Councillor also has previous work experience as the Environmental Services Coordinator and Environmental Technologist at the RDCK.</p><p><a href="https://www.mycrestonnow.com/27440/nelson-creston-bc-liberal-candidate-tanya-finley/">Tanya Finley</a> is making a push for the Liberals in the riding. Stepping down as the President of the Nelson and District Chamber of Commerce, Finley was also a Director with the BC Chamber of Commerce. In 2017, Liberal candidate Tanya Rae Wall finished third in Nelson-Creston with 5,087 votes, just 43 votes behind Green Party candidate Kim Charlesworth. Finley is looking to improve those numbers for the Liberals, who had 27.93% support, compared to 28.16% for the Greens and 42.19% for the NDP.</p><p>While Kim Charlesworth is not running for the Green Party again in 2020, long-time campaign manager <a href="https://www.mycrestonnow.com/27505/27505/">Nicole Charlwood</a> is. Serving the party in the riding for a decade, Charlwood is hoping 2017&#8217;s success can be compounded and lead to a BC Green victory.</p><p>The final candidate in Nelson-Creston is <a href="https://www.mycrestonnow.com/27480/nelson-creston-bc-libertarian-party-candidate-terry-tiessen/">Terry Tiessen</a>, a BC Libertarian. Tiessen is the first Libertarian to ever run in the riding. Although a new face in provincial politics, Tiessen attempted to run for the Libertarian Party of Canada in the 2019 federal election but his nomination papers were not successfully filed on time. He is one of 25 Libertarians running in 2020.</p><div id="attachment_27598" style="width: 1052px" class="wp-caption aligncenter"><a href="https://www.mycrestonnow.com/wp-content/uploads/2020/10/All-Candidates.jpg"><img aria-describedby="caption-attachment-27598" class="size-full wp-image-27598" src="https://www.mycrestonnow.com/wp-content/uploads/2020/10/All-Candidates.jpg" alt="" width="1052" height="520" /></a><p id="caption-attachment-27598" class="wp-caption-text">BC Green Nicole Charlwood (top left), Libertarian Terry Tiessen (top right), BC Liberal Tanya Finley (bottom left), and BC NDP Brittny Andersen are all running in the 2020 B.C. Election in Nelson-Creston. (Supplied by BC Green Party, Terry Tiessen, BC Liberal Party, and BC NDP)</p></div><h4>Boundary-Similkameen</h4><p>Save for one term, Boundary-Similkameen has strongly shown Liberal support since the 1960s. Voting for the defunct Social Credit Party from 1966 to 1991 when the current riding was represented by two members, the Liberals have since held power in the riding from 1996, nearly two stints of 25 years.</p><p>Jim Hewitt was the riding&#8217;s longest-serving MLA from 1975 to 1988, representing the area for 13 years with the Social Credit Party. However, voters switched to an NDP vote in 1988 where Bill Barlee served until 1996. Barlee was MLA when the riding was also represented by Social Credit MLA Ivan Messmer between 1986 and 1991. The NDP then had sole control of the riding for one term until 1996, which is when another Bill came into the political game.</p><p>In 1996, Bill Barisoff took the riding back to Liberal supporters, serving for one term. John Slater won for the Liberals in 2009, before Linda Larson won her first election in 2013 and presently served until the election was called by John Horgan and the NDP.</p><p>Petra Veintimilla, a Town Councillor in Oliver is now looking to step up for the Liberals in the riding. Veintimilla is following in Larson&#8217;s footsteps, as the incumbent MLA was formerly a Councillor and Mayor in Oliver before pursuing provincial politics.</p><p>The NDP are turning to Roly Russell to try and shake up the riding, potentially taking a seat away from the Liberals. The prominent public figure is an elected member of the RDKB Board of Directors for Rural Grand Forks. Russell is also the President of the Association of Kootenay Boundary Local Governments (AKBLG) and has taken a leave of absence to run in the election.</p><p>While Boundary-Similkameen does not have a Green candidate, Darryl Seres is running in the riding for the Conservatives. From Osoyoos, Seres has previous experience in the non-profit sector, and is on the Board of Directors for the Conservative Party of BC.</p><p>The final candidate in the riding is Arlyn Greig. One of only two candidates running for Wexit BC in the province, Greig and Peace River South candidate Dorothy Sharon Smith are the first in the party&#8217;s history. Forming less than a year ago, the party would wish for B.C. and the western provinces and territories to separate from Canada. Greig is from Osoyoos.</p><h4>Kootenay East</h4><p>A stronghold for the BC Liberal Party, Kootenay East has been represented by a Liberal MLA since 2001 when Bill Bennett claimed 61.85% of the votes over NDP candidate Erda Walsh. Before Bennett&#8217;s 16 years as MLA, the riding voted NDP from 1986 to 2001 and for the now-defunct Social Credit Party from 1975 to 1986.</p><p><a href="https://www.myeastkootenaynow.com/11667/kootenay-east-election-profile-tom-shypitka-bc-liberals/">Tom Shypitka</a> is seeking re-election, following his victory in 2017 over NDP challenger Randal MacNair. The former Cranbrook City Councillor gathered 56.57% of the total votes to retain the riding for the Liberals.</p><p>Shypitka and the party are looking to keep power, but they have a worthy challenger in former Cranbrook Mayor <a href="https://www.myeastkootenaynow.com/11687/2020-kootenay-east-election-profile-wayne-stetski-bc-ndp/">Wayne Stetksi</a>. Also the Member of Parliament (MP) for Kootenay-Columbia from 2015 to 2019 before his loss to current Conservative MP Rob Morrison, Stetski is looking to represent constituents at his third level of government with the NDP.</p><p>Fernie&#8217;s <a href="https://www.myeastkootenaynow.com/12030/kootenay-east-election-profile-kerri-wall-bc-greens/">Kerri Wall</a> is the riding&#8217;s candidate for the Green Party, a long-time Healthy Communities worker with Interior Health that has a plethora of experience with local governments.</p><div id="attachment_11917" style="width: 901px" class="wp-caption aligncenter"><a href="https://www.myeastkootenaynow.com/11914/kootenay-east-candidates-to-participate-in-virtual-elk-valley-candidate-forum-oct15/kootenay-east-election-candidates-2020-tom-shypitka-wayne-stetski-and-kerri-wall-bc-liberals-and-wayne-stetski-and-bc-greens-2/" rel="attachment wp-att-11917"><img aria-describedby="caption-attachment-11917" class="size-full wp-image-11917" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/10/Kootenay-East-Election-Candidates-2020-Tom-Shypitka-Wayne-Stetski-and-Kerri-Wall-BC-Liberals-and-Wayne-Stetski-and-BC-Greens-2.jpg" alt="" width="901" height="461" /></a><p id="caption-attachment-11917" class="wp-caption-text">Tom Shypitka (left), Wayne Stetski (middle), and Kerri Wall (right), all representing the respective BC Liberals, BC NDP, and BC Greens, are running to be the next MLA for Kootenay East in the 2020 B.C. Election. (Supplied by BC Liberals, Wayne Stetski, and BC Greens)</p></div><h4>Columbia River-Revelstoke</h4><p>The political battle in Columbia River-Revelstoke looks very similar to the one fought in 2017.</p><p><a href="https://www.myeastkootenaynow.com/11960/columbia-river-revelstoke-election-profile-doug-clovechok-bc-liberals/">Doug Clovechok</a> was elected for the Liberals, the party&#8217;s first victory in the riding since 2001, which only lasted a single term. Securing 45.44% support, Clovechok edged out NDP candidate and former Invermere Mayor Gerry Taft by 1,372 votes last election cycle.</p><p>Columbia River-Revelstoke has historically been an NDP riding since its creation in 1991. Jim Doyle was MLA for two terms for the NDP before Wendy McMahon&#8217;s victory in 2001. The NDP took the riding back under Norm Macdonald, who would go on to serve as MLA from 2005 to his retirement in 2017.</p><p>While Taft challenged Clovechok for the seat in 2017, <a href="https://www.myeastkootenaynow.com/12017/columbia-river-revelstoke-election-profile-samson-boyer-bc-greens/">Samson Boyer</a> was just of legal age when he ran for the BC Green Party. Boyer collected 1,708 total votes in 2017 (11.72%) as one of the youngest candidates that ran in all of British Columbia. Now three years older, Boyer is back representing the party in the riding and hoping to make some democratic changes if elected.</p><p>As the NDP geared up to try and retake the riding, <a href="https://www.myeastkootenaynow.com/11989/columbia-river-revelstoke-election-profile-nicole-cherlet-bc-ndp/">Nicole Cherlet</a> stepped forward as the nominee. The Revelstoke City Councillor is similarly looking to do what Tom Shypitka did for the Liberals in 2017 and make the jump from municipal to provincial politics from a City Council chair.</p><div id="attachment_11972" style="width: 1077px" class="wp-caption aligncenter"><a href="https://www.myeastkootenaynow.com/11969/online-election-forum-being-held-next-week-for-columbia-river-revelstoke-candidates/columbia-river-revelstoke-election-candidates-2020-doug-clovechok-nicole-cherlet-samson-boyer-bc-liberals-and-bc-ndp-and-samson-boyer/" rel="attachment wp-att-11972"><img aria-describedby="caption-attachment-11972" class="size-full wp-image-11972" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/10/Columbia-River-Revelstoke-Election-Candidates-2020-Doug-Clovechok-Nicole-Cherlet-Samson-Boyer-BC-Liberals-and-BC-NDP-and-Samson-Boyer.jpg" alt="" width="1077" height="583" /></a><p id="caption-attachment-11972" class="wp-caption-text">Doug Clovechok (left), Nicole Cherlet (middle), and Samson Boyer (right), all representing the respective BC Liberals, BC NDP, and BC Greens are all running to be the MLA for Columbia River-Revelstoke in the 2020 B.C. Election. (Supplied by BC Liberals, BC NDP, and Samson Boyer)</p></div><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="fb-comments-box"><div class="fb-comments" data-href="https://www.mykootenaynow.com/40588/2020-b-c-election-history-and-background/" data-num-posts="5" data-width="100%" data-colorscheme="light"></div></div></div></article><hr class="hr-thin-bottom"><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="post-related section-container clearfix"><h2 class="section-title">Recent Posts</h2><div class="row"><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-40578 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mykootenaynow.com/40578/local-voting-information-for-kootenay-west-2020-b-c-election/" title="Permalink to Local voting information for Kootenay West, 2020 B.C. Election" rel="bookmark">Local voting information for Kootenay West, 2020 B.C. Election</a></h3><div class="post-meta header-font">
<a href="https://www.mykootenaynow.com/40578/local-voting-information-for-kootenay-west-2020-b-c-election/" class="post-date" title="Permalink to Local voting information for Kootenay West, 2020 B.C. Election" rel="bookmark">Friday, Oct. 23rd, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mykootenaynow.com/40578/local-voting-information-for-kootenay-west-2020-b-c-election/" title="Permalink to Local voting information for Kootenay West, 2020 B.C. Election" rel="bookmark">
<img width="265" height="147" src="https://www.mykootenaynow.com/wp-content/uploads/2020/10/BC-Voting-Place-Elections-BC-Stock-Image-Elections-BC-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2020/10/BC-Voting-Place-Elections-BC-Stock-Image-Elections-BC-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2020/10/BC-Voting-Place-Elections-BC-Stock-Image-Elections-BC-360x200.jpg 360w, https://www.mykootenaynow.com/wp-content/uploads/2020/10/BC-Voting-Place-Elections-BC-Stock-Image-Elections-BC-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-40580 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mykootenaynow.com/40580/generous-donation-given-to-gyro-park-playground-in-trail/" title="Permalink to Generous donation given to Gyro Park Playground in Trail" rel="bookmark">Generous donation given to Gyro Park Playground in Trail</a></h3><div class="post-meta header-font">
<a href="https://www.mykootenaynow.com/40580/generous-donation-given-to-gyro-park-playground-in-trail/" class="post-date" title="Permalink to Generous donation given to Gyro Park Playground in Trail" rel="bookmark">Friday, Oct. 23rd, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mykootenaynow.com/40580/generous-donation-given-to-gyro-park-playground-in-trail/" title="Permalink to Generous donation given to Gyro Park Playground in Trail" rel="bookmark">
<img width="265" height="147" src="https://www.mykootenaynow.com/wp-content/uploads/2020/10/GyroParkPlaygroundProgress-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2020/10/GyroParkPlaygroundProgress-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2020/10/GyroParkPlaygroundProgress-360x200.jpg 360w, https://www.mykootenaynow.com/wp-content/uploads/2020/10/GyroParkPlaygroundProgress-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm"><article class="post-40569 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mykootenaynow.com/40569/interior-health-launches-online-booking-tool-for-covid-19-tests/" title="Permalink to Interior Health launches online booking tool for COVID-19 tests" rel="bookmark">Interior Health launches online booking tool for COVID-19 tests</a></h3><div class="post-meta header-font">
<a href="https://www.mykootenaynow.com/40569/interior-health-launches-online-booking-tool-for-covid-19-tests/" class="post-date" title="Permalink to Interior Health launches online booking tool for COVID-19 tests" rel="bookmark">Thursday, Oct. 22nd, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mykootenaynow.com/40569/interior-health-launches-online-booking-tool-for-covid-19-tests/" title="Permalink to Interior Health launches online booking tool for COVID-19 tests" rel="bookmark">
<img width="265" height="147" src="https://www.mykootenaynow.com/wp-content/uploads/2020/04/COVID-19-Testing-Coronavirus-Stock-Test-Tube-Pixabay-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2020/04/COVID-19-Testing-Coronavirus-Stock-Test-Tube-Pixabay-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2020/04/COVID-19-Testing-Coronavirus-Stock-Test-Tube-Pixabay-360x200.jpg 360w, https://www.mykootenaynow.com/wp-content/uploads/2020/04/COVID-19-Testing-Coronavirus-Stock-Test-Tube-Pixabay-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div></div></div></div><aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4"><div class="sidebar-inner"><div id="text-5" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div><div id="vw_widget_post_slider-6" class="widget vw-sidebar-blog widget_vw_widget_post_slider"><h3 class="widget-title"><span class="super-title">Sponsored Articles</span>Local Connections</h3><div class="post-box-list"><div class="flexslider no-control-nav post-slider"><ul class="slides"><li>
<a href="https://www.mykootenaynow.com/35538/floatation-therapy/" title="Permalink to Floatation Therapy" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc.jpg 810w, https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc-300x167.jpg 300w, https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc-768x427.jpg 768w, https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2019/06/floatsbc-8x4-lc-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Floatation Therapy</span></h3></div>
</a></li><li>
<a href="https://www.mykootenaynow.com/32448/undercover-secrets-to-a-great-fitting-bra/" title="Permalink to Undercover Secrets – To A Great Fitting Bra!" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4.jpg 810w, https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4-300x167.jpg 300w, https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4-768x427.jpg 768w, https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2019/01/Undercover-Secrets-LC-8x4-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Undercover Secrets – To A Great Fitting Bra!</span></h3></div>
</a></li><li>
<a href="https://www.mykootenaynow.com/31654/kootenay-family-dental-quality-consistent-dental-care-for-the-entire-family/" title="Permalink to Kootenay Family Dental – Quality, Consistent Dental Care for The Entire Family!" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4.jpg 810w, https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4-300x167.jpg 300w, https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4-768x427.jpg 768w, https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4-265x147.jpg 265w, https://www.mykootenaynow.com/wp-content/uploads/2018/12/kootenay-family-dental-LC-8x4-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Kootenay Family Dental – Quality, Consistent Dental Care for The Entire Family!</span></h3></div>
</a></li><li>
<a href="https://www.mykootenaynow.com/30918/7-reasons-why-local-connections-is-a-great-way-to-reach-your-business-goals/" title="Permalink to 7 Reasons Why Local Connections Is A Great Way To Reach Your Business Goals" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="833" height="468" src="https://www.mykootenaynow.com/wp-content/uploads/2018/11/local-connection-810x450.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mykootenaynow.com/wp-content/uploads/2018/11/local-connection-810x450.jpg 833w, https://www.mykootenaynow.com/wp-content/uploads/2018/11/local-connection-810x450-300x169.jpg 300w, https://www.mykootenaynow.com/wp-content/uploads/2018/11/local-connection-810x450-768x431.jpg 768w, https://www.mykootenaynow.com/wp-content/uploads/2018/11/local-connection-810x450-750x420.jpg 750w" sizes="(max-width: 833px) 100vw, 833px" /></div><div class=""><h3 class="title">
<span>7 Reasons Why Local Connections Is A Great Way To Reach Your Business Goals</span></h3></div>
</a></li></ul></div></div></div><div id="text-6" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-side v-promotional-carousel"><div class="v-side v-promotional"><ol><li><img src="https://www.mykootenaynow.com/wp-content/plugins/vista-addons/img/facebook-contest-like-300x90.gif"></li></ol></div></div></div></div><div id="text-7" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div><div id="text-16" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-tall-side v-promotional-carousel"><div class="v-tall-side v-promotional"><ol><li><a href="https://www.mykootenaynow.com/40413/crappy-closet-photo-contest/"><img src="https://www.mykootenaynow.com/wp-content/uploads/2020/10/CrappyCloset-333513-3x5-1.jpg" width="300" height="525"></a></li></ol></div></div></div></div><div id="text-17" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div></div></aside></div></div><footer id="footer"><div id="footer-nav"><div class="container"><div class="row"><div class="col-sm-5"><div class="v-footer-menu"><ul id="menu-footer" class="menu"><li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-67"><a href="https://www.mykootenaynow.com/news/">News</a></li><li id="menu-item-16688" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16688"><a href="https://www.mykootenaynow.com/win/">Win</a></li><li id="menu-item-66" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66"><a href="/community-calendar/">Events</a></li><li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.mykootenaynow.com/contact-us/">Contact Us</a></li><li id="menu-item-69" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69"><a href="https://www.mykootenaynow.com/advertise-us/">Advertise</a></li><li id="menu-item-16689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16689"><a href="http://www.vistaradio.ca/about/working-at-vista/">Careers</a></li></ul></div><div class="v-policy-menu"><ul id="menu-policy-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/privacy" target="_blank">Privacy Policy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/terms-of-service/" target="_blank">Terms Of Service</a></li></ul></div></div></div></div></div><div class="copyright"><div class="container"><div class="row"><div class="col-sm-6 copyright-left">
<a href="http://www.vistaradio.ca" target="_blank"><img src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/vista-logo-footer.png" width="86" height="30" border="0" alt="Powered by Vista Radio" /></a></div><div class="col-sm-6 copyright-right"><a href="http://radioplayer.vistaradio.ca" target="_blank"><img width="107" height="30" style="width:107px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/rpc-logo-w30.png"></a>
&nbsp;
<a href="https://itunes.apple.com/ca/app/radioplayer-canada/id1204742241" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-itunes1.png"></a>
&nbsp;
<a href="https://play.google.com/store/apps/details?id=ca.radioplayer.android" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-play1.png"></a></div></div></div></div></footer></div>  <script>(function($){$(function(){$('body').prepend('<div class="vern" id=""><div><span>&#x2744;</span> Special Weather Statement issued for most of southeastern B.C. <a href="https://www.mykootenaynow.com/?post_type=post&p=40540" class="vern-btn">read more &raquo;</a></div></div>');});})(jQuery);</script> <style>.vern{background-color:#d35151;color:#fff;width:100%;font-size:16px;line-height:1.5;padding:10px;box-sizing:border-box}.vern div{max-width:1200px;width:100%;margin:0 auto;padding:4px 0;overflow-wrap:break-word;word-wrap:break-word;word-break:break-word;-ms-hyphens:auto;-moz-hyphens:auto;-webkit-hyphens:auto;hyphens:auto}.vern div span{font-size:1.7em;margin-right:4px;position:relative;top:3px;fill:#fff}.vern-btn{background-color:#f6ae42;border:none;color:#fff;padding:3px 6px;text-decoration:none;display:inline-block;font-size:14px;margin-left:4px;border-radius:2px;text-decoration:none}.vern-btn:hover{text-decoration:none;background:#5c89cc}.vern:after{content:"";display:table;clear:both}</style> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js');})(document.body);</script> <script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/cf49e.js'></script> <script type='text/javascript' src='https://ras.vistaradio.ca/dist/asyncj.php?ver=5.4.2'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/126cd.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/6cdff.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/97d52.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/bbc6b.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/59a15.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/fcc89.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/93fc2.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/839a6.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/c7008.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/5dc08.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/e0cc7.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/e92d8.js'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/main.js?ver=2.0'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/custom.js?ver=5.4.2'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/d5efd.js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mykootenaynow.com/wp-content/litespeed/cssjs/eeadd.js'></script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create','UA-56914607-5','auto');ga('require','displayfeatures');ga('send','pageview');</script> <script type='text/javascript'>;(function($,window,document,undefined){"use strict";$(document).ready(function($){$('.flexslider').flexslider({animation:"fade",easing:"easeInCirc",slideshow:true,slideshowSpeed:4000,animationSpeed:600,randomize:false,pauseOnHover:true,prevText:'',nextText:'',start:function(slider){slider.css('opacity','1');slider.find('.post-thumbnail-wrapper').css('height','500px').imgLiquid().fadeIn(250);},});});})(jQuery,window,document);</script> <div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=335982600081119&version=v2.3&";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <style>.main-nav{margin-top:-25px !important}</style></body></html>
<!-- Page optimized by LiteSpeed Cache @2020-10-24 13:42:07 -->
<!-- Page supported by LiteSpeed Cache 3.2.4 on 2020-10-24 06:42:07 -->